logo头像
kongfl888

当前位置: 首页 > 正文

关于Net Framework的使用

本文于1963天之前发表,文中内容可能已经过时。

至所有用户及开发者,
你还在使用Net3.5作为开发环境么,你还在使用Net3.5这个庞大物么,但现在,我都毫无犹豫地推荐大家放弃Net3.5。虽然我们曾经为了兼容更多的系统,我们更多地选用Net Framework 3.5作为我们的开发环境,但就如同xp一般,微软抛弃3.5是迟早的事。从Windows8开始早已不再集成,尽管预留了功能支持,但只要微软愿意,彻底抛弃是迟早的事。

Net4.0所带来的不仅仅只是技术的优越,其对代码集的优化程度要比3.5家族好了不止那么一点。而且不管是对于开发者还是对于用户而言,其运行库的大小是这般地让人汗颜,一个完整版的Net Framework 3.5 的运行库仅仅只是安装包就足足有两百M,这对于用户和开发者来说都是一个很庞大的数字。尽管微软曾经为此增加了一个作为精简的Client Profile版本,但这也是杯水车薪。

幸运的是,4.0作为支持XP的最后一个Net Framework版本,这让我们有了更好地选择。所以作为XP用户,我推荐你毫不犹豫地安装Net4.0;作为Windows7用户,我同样也毫不犹豫地推荐你安装及升级为最新版本的Net4.5家族。Net4家族是可以向下兼容的,就是说你只要有一个就够,不需要重复安装。

我们可以从微软的文档了解到,Net3.5只有Windows7才自带,而Windows8之后,Net4.x已经被集成,运行Net4.0程序毫无压力,也不需要引导用户安装NET4的库,而作为Windows7用户,为了某些聊天软件和大型游戏,他们早就备有了Net4.x,根本不需要你们引导他们安装。

所以,我毫无犹豫地推荐大家伙直接使用Net4.0,4.0是一个很不错的兼容物,后期转投新版本的4.6也同样是低成本。作为封装系统的爱好者,抛弃3.5这个庞大物吧,这能让你的系统更小。作为用户,如果你还在被动地使用Net3.5,直接把这篇文章告诉该程序的开发者。

你不一定能看到这篇文章,如果有幸有人看到,那建议你听我一言。

另附系统已集成的Net Framework说明:

1.jpg

附,运行库分享地址:运行库


2015年5月21日记

kongfl888


发个红包吧,亲,点击上方按钮,多少都是心意,本站的持久离不开您的支持


上一篇